Certain organizations unable to see the 'Save' button at the bottom of the Register's transaction creation screen

Incident Report for aplosstatus

Resolved

The team has identified the issue, and a fix has been prepared and released. All organizations should have visibility of the missing transaction-creation buttons in the Register.
Posted Mar 11, 2026 - 17:29 UTC

Investigating

Certain organizations have no visibility of the footer buttons at the bottom of the Register's `Create a Payment` or `Create a Deposit` screens, which normally allow them to cancel or save their transaction.

The team is actively investigating and has discovered a workaround in the meantime: from the `Amount` field, press 'TAB' on your keyboard twice. This will cause the buttons to become available again, allowing you to save your transactions.
Posted Mar 11, 2026 - 16:07 UTC
This incident affected: Accounting.