Events Page Not Displaying
Incident Report for aplosstatus
Resolved
This incident has been resolved.
Posted Aug 21, 2023 - 20:23 UTC
Investigating
The Events management page (Donations > Events) is not displaying for many customers. We have identified the root cause and are working on a solution.
Posted Aug 21, 2023 - 19:49 UTC
This incident affected: Payment Processing.