Updating a Bank Account in the Merchant Center is unavailable.
Incident Report for aplosstatus
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 21:17 UTC
Identified
We have identified the issue and are preparing to release a fix.
Posted Sep 08, 2023 - 20:44 UTC
Investigating
Updating a Bank Account in the Merchant Center is not available at this time.
Posted Sep 08, 2023 - 17:50 UTC
This incident affected: Payment Processing.