Emails failing for Hotmail/Outlook

Incident Report for aplosstatus

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 22:09 UTC

Investigating

Following the fix that was implemented to resolve failed deliveries to Microsoft addresses, many backlog messages were sent at once. This created a small window in which messages sent to non-Microsoft addresses also failed. We quickly made an additional fix, and are seeing messages be delivered again. Microsoft address recipients may still see some impact, and our team continues to investigate.
Posted Feb 25, 2026 - 22:33 UTC

Monitoring

We have made a change and are monitoring the results of that change.
Posted Feb 25, 2026 - 21:26 UTC

Investigating

We are aware of an issue affecting email delivery to Outlook and Hotmail recipients. Our team is actively investigating the cause and working to restore normal delivery as quickly as possible. We will provide updates as we have them.
Posted Feb 25, 2026 - 20:03 UTC
This incident affected: Communication (Email Campaigns).